Gerfried Fuchs uploaded new packages for postgresql-8.4 which fixed the
following security problem:

  The PL/perl and PL/Tcl implementations in PostgreSQL 7.4 before
  7.4.30, 8.0 before 8.0.26, 8.1 before 8.1.22, 8.2 before 8.2.18, 8.3
  before 8.3.12, 8.4 before 8.4.5, and 9.0 before 9.0.1 do not properly
  protect script execution by a different SQL user identity within the
  same session, which allows remote authenticated users to gain
  privileges via crafted script code in a SECURITY DEFINER function, as
  demonstrated by (1) redefining standard functions or (2) redefining
  operators, a different vulnerability than CVE-2010-1168,
  CVE-2010-1169, CVE-2010-1170, and CVE-2010-1447.

For the lenny-backports distribution, the problem has been fixed in
version 1.8.5-1~bpo50+1.

For the current testing (squeeze) and unstable (sid) distributions, the
problem has been fixed in version 1.8.5-1.

Upgrade instructions
- --------------------

If you don't use pinning (see [1]) you have to update the package
manually via "apt-get -t lenny-backports install <packagelist>" with
the packagelist of your installed packages affected by this update.
[1] <>

We recommend to pin the backports repository to 200 so that new
versions of installed  backports will be installed automatically.

  Package: *
  Pin: release a=lenny-backports
  Pin-Priority: 200